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INTRODUCTION AND SAFETY WARNINGS

This is a tutorial aid for laboratory practice in AXX9012 Teaching Practice intended for
doctoral students and staff whose professional activity concerns education in the field of
electrical drives. The goal of this work is to study the methodology of labs preparation,
execution and reporting, to assest the instructor’s and learner’s roles, and to prepare
recommendations relatively further teaching improvements.

SAFETY WARNINGS
Prior to start working on the laboratory setups, a learner is expected to have acquired
knowledge of basics of electrical engineering, electronic components, standard electrical
wiring, and electrical schematic symbols. As works are conducted on real industrial
potentially dangerous equipment, the following safety warnings are to be fulfilled without fail.
1. Always remember the laboratory setups are dangerous device. Never apply power
and never run the motors if it may cause danger or an injury.
2. Before powering the laboratory setup, make sure all equipment and measuring
instruments are suitable for operation throughout the permissible speed, voltage, and
current ranges.
3. Never power on equipment without instructor’s permission.
4. In the case of overheating, smelling, the sparkles or electric arc, switch off the power
source immediately by the STOP button, emergency push-button, the main switch on
the cabinet console, or the red safety push-button on the laboratory switchboard.
5. To avoid electric shock, never open the covers and do not touch the cables or the
motors while the mains power is applied or the shafts rotate.
6. Do not run the motors over the nominal speed continuously and do not allow their
long-term overloading.
7. Do not control the motors by direct device connecting/disconnecting; instead, use the
control keys and buttons.
8. Do not exceed 5 power-ups in 10 minutes to exclude the installation damage.
9. If the work is done remotely, follow the instructions concerning the net connection.
Before the lessons,
•
•

download this manual or update it and read carefully the required work contents
prepare the protocol of the future work with tables of observations for all the tasks
related to your variant.

During the lessons,
•
•
•

implement the work step by step
fill your observations in the report tables
solve the problems

After every lesson, present your report with the work protocol to the instructor, correct, and
defend it if required. Clearly, deficiencies may be encountered in these regulations. Thus
your commentaries, remarks, and criticism are appreciated.
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1. CONTROL OF SERVO DRIVE
As an outcome of this work, a learner must
•
•
•
•
•

to understand the work methodology
to find the benefits and drawbacks of the proposed approach
to evaluate the work connection with the basic course outcomes
to suggest the work rearranging
to prepare recommendations about the learning process enchancement

1.1. Laboratory setup
The TP 801 servo drive equipment set includes an axis slide with two limit switches, servo
motor MTR-AC-55, servo controller SEC-AC-305 with a testbox, the set of power and
encoder cables, and the toolkit Wmemoc with preliminary assigned options and Festo
parameters. Electrical and mechanical data of the MTR-AC-55 servo motor are as follows:
Parameter
Rated voltage
Rated current
Maximal current
Rated torque
Maximal torque
Rated speed

Unit
[V]
[A]
[A]
[Nm]
[Nm]
[rpm]

Value
325
2,15
6,4
0,66
0,98
6800

To begin, establish communication between the personal computer (PC) and the SEC-AC
controller. Before operation, the testbox and PC are to be connected to the controller and the
mains power supply switch is in the OFF position. In the testbox all the toggles are OFF and
potentiometers in 0 positions.
•
•
•

Move the axis slide to the mid position of the axis.
Switch ON the mains power supply (230 VAC) mounted on the controller.
Switch ON the 24 VDC power supply.

After an internal self test, the READY LED on the front of the SEC-AC lights up. Powering
OFF the system is to be conducted in reverse sequence.
To establish communication between PC and SEC-AC, start Wmemoc on PC (if you
start before this, an error message will occur). At normal communication, Wmemoc
appears with three windows – Commands, Status and Actual Values.
To assign the Wmemoc options,
•

Select Actual Values from menu and tick all values – this activates the Actual
values dialog box.
• Select Options > User Mode > Expert. This ensures that you have access to all
functions of Wmemoc.
To load the parameter set,
•

•

Select File > Parameter set > Read from file and store into servo.

•

Use the browser dialog box to find the correct parameter set. You should be in the
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Wmemoc folder called wpa (.wpa is the file extension for parameter sets).
The laboratory setup is provided with completly predefined parameter sets for all
Festo axes–servo motor combinations (horizontal and vertical). These predefined
parameter sets arrange an initial controller configuration for commissioning. Select
the parameter set DGE 18ZR-AC55-3S-Ax_h for the motor and controller used in the
setup, ensuring the horizontal position is selected.
Click OK to load the parameter set. A bar appears showing the downloading
progress. On completion, the message "Data transferred" appears.
Store data from SEC-AC RAM into SEC-AC EEPROM: Parameters > Save
parameters. From now on, your data are saved even in the case of 24 VDC power
failures.

•

•

•

1.2. Commissioning the servo drive
The commissioning procedure is intended for manual equipment validation, assigning
Command and Reference Position settings, and enabling the system.
To commission the equipment by hand,
Move the slide in both directions. Ensure that the counter for the Position value in
the Actual values dialog box is counting up and down.
Check the functioning of the limit switches: the counter should count up until reaching
the limit switch. Then, Limit switch 1 lights up in the Status dialog box.
Check in the other direction – the counter counts down until Limit switch 0 lights up
in the Status dialog box.

•
•
•

Variant
1
2
3
4

Task 1
Experiment
Measure the slide Position at Limit switch 0
Measure the slide Position at Limit switch 1
Calculate the slide maximal distance between
the limit switches
Set the slide to the mid Position.

Observation
Limit switch 0 =
Limit switch 1 =
Max =
0

1.3. Reference move
To work accurately, servo drives need a reference point from which all positions are
calculated. Two reference points are available: left and right.
To execute the reference move,
•
•
•
•

•

•

Switch ON the power stage Endst toggle (LED lights up).
Switch ON the controller Regler toggle (LED lights up).
Read the drive state in the Status dialog box.
In the Commands dialog box, tick the following settings: Drive enable, Motor speed
control, Position control, and Positioning. Be careful: the system will start
automatically when enabled/powered.
The 7-segment display on the SEC-AC lights up showing "P" (“Positioning”).
Ensure manually thay the slide is locked into position and cannot be moved.
You can now hear a slight noise from the servo controller.
Click Reference move icon

to open the Reference position dialog box.
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•
•
•

Set Destination parameter max. turns permitted to 6,5.
Select Method 1 in the Mode box.
Select Turn right in the Direction box.

The next step will cause movement of the slide – make sure there is nothing obstructing the
path of drive and everyone around you knows you are going to start.
•

In the Reference position dialog box click GO! The slide moves to the reference
point and stops. In the Actual values dialog box ensure that Position is 0. In the
Status dialog box ensure that In position lights up.

If the system is noisy or moves erratically, power off the controller and tell the instructor.
•
•
•
•
•

Change Direction and repeat the reference move.
Click OK to close the dialog box.
Return controller Regler to OFF (toggle down) - LED becomes dim.
Return power Endst to OFF (toggle down) - LED becomes dim.
All other toggles are to be OFF and potentiometers at 0.

1.4. Speed control
Tune the testbox as follows:
•
•

Set Analog-IN 0,1 toggle to Ground.
Turn Analog-IN 0 potentiometer to 0.

Change the Wmemoc settings as follows:
•
•
•

In the Commands dialog box, select Motor speed control and clear all other
checkboxes.
Select menu Set points > Set point selection.
In Selector A tab, select Analog input 0 and click OK. This ensures that the
controller is checking analog input 0.

For safety reasons and for setting the permissible speed of a drive in applications, restrict the
speed of the axis. To this aim,
•
•
•

•

Select menu Parameters > Device parameters > Set point scaling.
Choose the tab Channel 0 and change the scale of upper limit to 200. This means
that at 10 V the system operates at 200 rpm. This value is activated immediately.
Click the Auto offset calibration button. If you have drift on ground – the motor turns
without any input signal – this compensates for it. This is the default value and must
be adapted during commissioning to suit an application!
Click OK to close the dialog box.

Now, the system can be enabled via the testbox:
•
•
•

Check again that the analogue potentiometer is at 0 and the switch Analog-IN is set
to Ground.
Enable power stage (Endst) and controller (Regler).
Switch ON Analog-IN 0,1 toggle.

Turn potentiometer Analog-IN 0,1 to adjust the speed and direction of the slide, observe the
slide reaction, and log your observations in the table below:
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Variant
1
2
3
4
•

Task 2
Experiment
Turn potentiometer slowly clockwise.
Return potentiometer to 0.
Turn potentiometer slowly counter-clockwise.
Return potentiometer to 0.
Turn potentiometer quickly clockwise.
Return potentiometer to 0.
Turn potentiometer slowly clockwise and
switch analogue toggle from ON to Ground.
Return analogue switch from Ground to ON.

Observation

Disable the power stage and controller.

1.5. Positioning
The positions, speeds and ramps have to be defined before they can be called in a program.
Therefore it is important to know how these parameters are defined and stored in the system.
To check positions,
•

Allocate the slide in the mid position of the axis.

• Click Position
icon. The Destination 0 dialog box appears.
In the boxes Acceleration and Deceleration you can parameterize the ramps for
accelerating and decelerating the drive. If the time in the field Smoothing is 0, this will result
in linear ramps; otherwise the ramp shape will be parabolic. Switching along the Select box,
define the following positions from 0 to 12:
Pos.

Position [R]

0
1
2
3
4
5
6
7
8
9
10
11
12

20 % of Max
80 % of Max
40 % of Max
50 % of Max
Max
50 % of Max
5 % of Max
10 % of Max
80 % of Max
90 % of Max
Max
-10 % of Max
10 % of Max

Running speed
[rpm]
100
200
300
400
500
200
250
300
400
500
500
300
300

Positioning run
absolute
absolute
absolute
absolute
absolute
absolute
absolute
absolute
absolute
absolute
absolute
relative
relative

Acceleration
[msec]
400
100
100
100
100
400
400
400
400
400
100
400
400

Deceleration
[msec]
400
100
100
100
100
400
400
400
400
400
100
400
400

Here Position [R] is given according to the positioning mode, which may be relative
(calculated from the last position), or absolute (calculated form the reference point).
After that, move to the selected positions:
•
•

Enable power stage (Endst) and controller (Regler).
Execute the reference move.

•

Click Go to destination button

in the toolbar.

Now you can click buttons in the dialog box to move to a selected position.
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•

Select the positions in the sequence shown in the table below starting from the
reference move to the proper direction (left or right). As you go, make notes in the
table about the motion of the slide.
Task 3

Variant

1

2

3

4

•

Step
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31

Move to position
Reference move
1
0
2
0
3
0
4
0
5
0
6
0
7
0
8
0
9
0
10
0
7
7
11
11
12
12
12
7
7
0

Observation

Upon completion, disable the power stage and controller.

1.6. Torque control
Torque control is an important feature and benefit that offers safety to man, machine and
products. Unlike the steppers that do not allow any torque control, servo motors are able to
control torque easily by increasing its current to ensure that the torque remains.
Before experimentation,
•
•
•

Move the slide to the mid position of the axis.
Set Analog-IN 0,1 toggle to Ground.
Turn Analog-IN 0 potentiometer to 0.

Assign the software settings as follows:
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•
•
•
•
•
•
•

In the Commands dialog box, select Torque control and clear all other options.
Select menu Set points > Set point selection > Selector A.
Select tab Analog input 0 and click OK. The drive torque is now regulated by the
analogue input 0.
Select Parameters > Device parameters > Set point scaling.
In tab Channel 0 set the scale maximum peak to 0,2 Nm. Note that all values are
immediately effective! Do not set more than 0,2 Nm because of danger of injury!
Click the button Auto offset calibration.
Click OK to close the dialog box. Make sure that the slide is positioned in the middle
of the axis and there are no obstacles in the way.

Accurately enable the system because it may cause movement of the slide:
•
•
•

Enable power stage and controller.
Switch ON Analog-IN 0,1 toggle.
Follow the instructions in the table below. By observing the Actual values dialog box,
establish at what torque the slide starts to move.

Variant
1

2

3
4
1
2

3

4
•
•

Task 4
Experiment
Slowly turn the potentiometer fully
clockwise. What Torque the slide starts
to move at?
Slowly return to 0.
Slowly turn the potentiometer fully
counter-clockwise. What Torque the slide
starts to move at?
Slowly return to 0.
Turn OFF the Analog-IN 0,1 toggle
(Ground).
Set the potentiometer to any position.
Turn ON the Analog-IN 0,1 switch.
What Torque the slide starts to move at?
Move the slide to one of the end positions
While holding the slide in the end
position, slightly turn the potentiometer to
move the slide to the other end. What
Torque the slide starts to move at?
While holding the slide in the end
position, gradually turn the potentiometer
to increase the force. Do not increase the
maximal Torque. What Torque the slide
starts to move at?
What would you consider about the safe
setting that would avoid injury to people?

Observation

Upon completion, set all the toggles of the testbox to OFF positions and turn the
potentiometers to 0.
Switch OFF the laboratory setup.
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1.7. Problems
Variant

1

2

3

4

Problems
2.1. Call the main commissioning functions of Wmemoc.
2.2. Is the SPC 200 always essential?
2.3. What dictates the maximal speed of the servo drive?
2.4. What should be done to decrease slippage?
2.5. Why the ramps are required?
2.1. What signals SEC-AC and testbox exchange?
2.2. Explain the needs in the speed control and its problems.
2.3. How can you change the speed?
2.4. What factors affect the resolution of a position the slide is moving to?
2.5. How long can a ramp be?
2.1. How to establish communication between PC and SEC-AC?
2.2. Explain the needs in the position control and its problems.
2.3. How flexible (precise) are the speeds executed by the servo motors?
2.4. What the distance the slide moves per the motor revolution depends?
2.5. Why the torque control is an important feature?
2.1. When a reference move is required?
2.2. How the positions, speeds and ramps are defined and stored in the system?
2.3. What must be done if slippage is suspected?
2.4. How do you start Wmemoc programs or projects?
2.5. What conclusion can you draw regarding the laboratory setup safety?

1.8. Report contents
•
•
•
•

functional diagram of the laboratory setup and the nominal data
tables of observations for the tasks related to your variant
a table with your program
solutions of the problems related to your variant

10

2. CONTROL OF STEP DRIVE
As an outcome of this work, a learner must
•
•
•
•
•

to understand the work methodology
to find the benefits and drawbacks of the proposed approach
to evaluate the work connection with the basic course outcomes
to suggest the work rearranging
to prepare recommendations about the learning process enchancement

2.1. Laboratory setup
To work with the step drive, a stepper MTR-ST, a pulse/direction controller SPC 200, and a
stepper card SEC-ST connected to the power supply and PC are used.
The axis is fixed to the H-rail support brackets. The stepper MTR-ST is attached to the axis
via the special adapter flange on the coupling housing and tightens the knurled screws. The
control assembly is fitted on the profile plate. Electrical connections are made for two limit
switches and the reference switch. The signal cable is connected between SPC 200 and
SEC-ST. The motor cable links MTR-ST to the SEC-ST. The power supply provides
equipment with 24 VDC. SPC 200 converts programs into pulse direction signals. The SECST converts these into the appropriate electrical power signals for the stepper. In this way,
SPC 200 activates the slide motion from the stepper via SEC-ST. SPC 200 can be replaced
by a PLC with integrated pulse direction card or by any other pulse direction source.
Electrical and mechanical data of the MTR-ST-42-48S-AA series stepper are as follows:
Parameter
Rated voltage
Rated current
Holding torque
Full step angle
Winding resistance
Winding inductance
Moment of inertia
Product weight
Feed constant

Unit
[V]
[A]
[N·m]
[°]
[Ω]
[mH]
[kg·cm² ]
[kg]
[mm/rev]

Value
48
3.1
1.27
1.8 ± 5 %
1 ± 10 %
3.8 ± 20 %
0.48
1.2
52

On the front panel of SEC-ST, 8 DIP switches are placed:
Name
Step Mode
Step Mode
Step Mode
Current

Switch ON/OFF Name Switch ON/OFF
1
OFF
Current
5
OFF
2
ON
Current
6
OFF
3
OFF
I-Red.
7
ON
4
OFF
Enable
8
ON

Changes on the DIP switches become valid only after power OFF/ON sequence.
The DIP switches 1, 2 and 3 assign the step mode as follows:
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Steps/rev
DIP
1
2
3

200
Full
ON
OFF
OFF

400
Half
OFF
ON
OFF

800
Quarter
ON
ON
OFF

1000
Fifth
OFF
OFF
ON

1600
Eight
ON
OFF
ON

2000
Tenth
OFF
ON
ON

The distance the slide moves per mm positioning path (drive resolution) is equal to the ratio
between the number of steps per revolution and the feed constant given in electrical and
mechanical data sheet.
The DIP switches 4, 5, and 6 assign the current value if the Current reduction DIP switch 7
(I-Reg) is ON. Current reduction provides energy saving and reducing motor heating.
DIP
4
5
6

DIP 7
ON
ON
ON
OFF

Current
1,25 A
1,50 A
1,80 A
Max

It can be used as a safety function for torque reduction in holding positions.

2.2. Running the project
To run the laboratory setup,
•
•
•
•
•
•

Ensure that the power supply is switched OFF.
Check that all electrical connections are secure.
Ensure that the DIP switches of SEC-ST are set as shown in table above.
Ensure that the path of the slide is clear of obstructions
Move the slide to the mid position.
Switch ON the power supply and wait while both SPC 200 Power LED and the
stepper card SEC-ST Power LED light up.

To start the project,
•
•
•

•

Run WinPISA.
Select Open project and open the sample project festoxx.prj.
Click Connect icon in the program toolbar (always connect before your PC
communicates with the SPC 200). The plug joins to show that the connection is
made.
Download the project to SPC 200 using menu Online > Download > Project. As a
warning dialog box is displayed, click Continue.

2.3. Commissioning the step drive
Select menu Online > Commissioning > Reference travel (Fig. 3.7). As a warning
dialog box is displayed, click Continue.
The Reference travel window allows checking the status inputs, activation reference move
or emergency travel, and running movements with negative and positive buttons.
•

The next step will cause movement of the slide – make sure there is nothing obstructing the
path of the drive and everyone around you knows you are going to start.
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Variant
1
2
3
4
•

Task 1
Operation
Click Start button and read the actual position of
the reference point
Click positive button and read the change of the
actual position upon the single button click
By clicking positive button, read the maximal
permissible distance of the slide movement accurate
with a millimetre.
Click negative button. How then can you return to
the reference poin?

Observation
Start =
Step =
Max =

Once you have completed commissioning, click Exit.

2.4. Reference move
To work accurately, step drives need a reference point from which all positions are
calculated. The reference point is reset in the reference move, which must be conducted
after powering up a step drive and whenever slippage (loss of steps) has occurred. Always
move to the reference point before engaging to any new position. Before the reference move
execution, WinPISA must be started, power supply switched ON, and the project
downloaded.
•

Select Online > Control axes. After a short time a dialog box Program selection
appears.

•

Select Program 1 for the reference move and click Ok. Following the warning
message click Continue.
After a short loading time, Program 1 is open (Fig. 3.1).

•

Fig. 3.1. Debug wimdow

Next step may cause movement of the slide. Ensure that the path of the slide is clear of
obstructions and the slide is in mid position.
•

•

Click the Execute step icon. The reference move will now be done. The motor turns
until the slide reaches the reference switch. The slide is now set to the reference
position.
Close Program 1.

2.5. Speed control
In practice, to vary the velocity of the slide, the frequency of supply pulses is changed.
Before the experiment execution with different velocity profiles, the step drive must be
running, WinPISA starting, and the sample project festoxx.prj open. Your goal is to create a
simple WinPISA program for the speed diagram.
You must develop the new program, which includes 9 records:
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Record
0
1
2
3
4
5
6
7
8

Move to Position
80 % of Max*
20 % of Max
80 % of Max
20 % of Max
80 % of Max
20 % of Max
80 % of Max
20 % of Max
End of Subroutine

Speed
20 %
20 %
50 %
50 %
70 %
70 %
100 %
100 %

*Calculate each position in mm using Max from Task 1.
To prepare the required program, do the following:
•
•

Save the current project as your new project: File > Save as and give it your name. In
this new project, the “Reference Move” program already exists as Program 1.
Select Software icon in the project window (Fig. 3.2).

Fig. 3.2. Project window

•
•

•
•

Select Insert object from Edit menu or press Insert key. A New program dialogue
window appears.
In the New program dialogue window, print a program title “Velocity Profiles” in the
Title field, author’s names in the Description field, and the program number 2 in the
Program no. field.
Click Ok to confirm your entries. The new program appears in the project window as
Program 2 with the program window opened.
Type your oun records in the Program window similarly to those shown in Fig. 3.3.

Fig. 3.3. Program example

Your program should comply with the syntax specified in DIN 66025. Every record starts with
the record number following a command with the appropriate parameters.
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For example, the first record in Fig. 3.3 calls the motion at 10 % of the maximal speed to the
position X = 100 mm. The second record calls the motion at the same speed to the position
X = 200 mm. The last record calls the program end with repeat. Here,
Code
N0000
G01
G90
X220.00
FX10
Y100.00
FY80

Description
Record number
NC command
Type of positioning (optional)
X axis position
X axis speed parameter (FX0 in the
case of 100 %)
Y axis position (optional)
Y axis speed parameter (optional)

A record number begins with the letter N. The records are numbered strictly ascending
(N000, N001, N002...). Other identifiers are listed in the table below:
Identifier
N
G
M
X, Y, Z, U
F
E
L

Description
Identifier for record number
Preparatory command function
Auxiliary command function
Axis identifiers: X-axis, Y-axis, etc
Move speed
Jump function
Subroutine call

The command functions are as follows:
Command
G00
G01
G02
G04
G08
G09
G74
G90
G91
M00
M02
M30

Function
Move to position at the highest permissible speed
Move to position at specified speed
Move to position at start/stop frequency
Dwell time
Acceleration for approach ramp
Deceleration for brake ramp
Start reference travel
Absolute measurement
Relative measurement
Program stop
End of subroutine
End program with repeat

After completing, check your program for correct syntax. To this aim,
•
•
•

•

Make sure that the window of the program to be checked is active.
Save the program.
Select Syntax check from Compile menu or click the Syntax check icon. The
progress of the syntax check will be displayed in Compile window. Wait until the
checking procedure is complete.
Click Ok in the Compile window to confirm the completed check. If there is an error,
a new window appears showing you where the error occurs. Clicking on the error line
will bring you to the place where the error occurs in the program box. Eliminate any
errors displayed, save the program, and repeat the syntax check. Finally, close
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•
•

Message window
Ensure that the icon plug shows that the connection is made.
Download the compiled project (Online > Download > Project).

To test your “Velocity Profiles” program,
•
•
•
•
•

Select Online > Control axes.
Choose Program 2 and click Ok.
While Debug window is active, you can execute it step by step (Execute step icon)
or continuously (Start icon).
Click Execute step icon.
Go through the lines of the program step by step (Fig. 3.4), observing the different
velocities (20, 50, 70 and 100% of the maximal speed).

Fig. 3.4. Program execution steps

•

Fill in your observations in the Observation column of the table below.
Task 2

Variant
1
2
3
4
•

Record
0
1
2
3
4
5
6
7

Observation

Close the Program 2 window keeping the project open.

2.6. Positioning
The positions have to be defined before they can be called in a program. To execute the
position move, the step drive must be running, WinPISA starting, and your project
downloaded. Your new program must have 9 records colling the slide to move at half of the
maximum speed:
Record
0
1
2
3

Move to Position
10 % of Max
25 % of Max
50 % of Max
75 % of Max
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4
5
6
7
8
•
•
•

90 % of Max
10 % of Max
90 % of Max
50 % of Max
End of subroutine

Create a new program in accordance with the table above.
Once completed, do a syntax check and save the program as “Position Profiles”. It
should be the Program 3.
Download the project (Online > Download > Project).

To test the “Position Profiles” program,
•
•
•
•
•

Select Online > Control axes.
Choose Program 3 (“Position Profiles”).
While the program is active, click Execute step icon.
Go through the lines of the program step by step, observing the different positions.
Fill in your observations in the Observation column of the table below.
Task 3
Variant
1
2
3
4

•

Record
0
1
2
3
4
5
6
7

Observation

Close the Program 3 window keeping the project open.

2.7. Setting ramps
With too hard acceleration or deceleration you can lose steps. Therefore, the speed ramping
up and down is an important feature for providing smooth but fast motion. You have to find
the profile for the individual movement dependently on the system performance, the length of
the axes, the maximal velocity, the slippage, and the load. In practice, you should not start
with more than 200 Hz as it will accelerate too fast.
To execute ramping, the step drive must be running, WinPISA starting, and your project
downloaded. If you have undefined starting conditions, activate first the reference move and
only afterwards test your program.
Your new program must provide the motion between the two positions with the required
acceleration and deceleration at the maximal speed:
Record
0
1
2
3

Move to Position
90 % of Max
10 % of Max
90 % of Max
10 % of Max

Acceleration
10 %
10 %
100 %
100 %
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Deceleration
10 %
10 %
100 %
100 %
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4
5
6
7
8
9
10
11
12
•

90 % of Max
10 % of Max
90 % of Max
10 % of Max
90 % of Max
10 % of Max
90 % of Max
10 % of Max
End of subroutine

10 %
10 %
100 %
100 %
50 %
50 %
100 %
100 %

10 %
10 %
100 %
100 %
50 %
50 %
100 %
100 %

Using the table above, create the new program similarly to those shown in Fig. 3.5.

Fig. 3.5. Program example

The description of the program is as follows:
NC Record
N000 G08 X0
N001 G09 X20
N002 G01 X20.00 FX0
N003 G01 X180.00 FX0
N004 M02

Description
Accelerate 100 %
Decelerate 20 %
Move at 100 % of the maximal speed to position X = 20 mm
Move at 100 % of the maximal speed to position X = 180 mm
End of subroutine

In the records “N000” and “N001” the acceleration and deceleration are assigned. Next, the
motion is described in “N002” and “N003”. The acceleration and deceleration would be
retained until they are changed further down the program. Any time as you need to change
acceleration or deceleration rate, set the new G08 and G09 commands.
•
•
•
•
•

Once completed, do a syntax check and save the program as “Ramp Profiles”.
Download the project (Online > Download > Project).
Select Online > Control axes.
Select Program 4 (“Ramp Profiles”) and click Ok.
Go through the lines of the program step by step clicking Execute step icon and
observing the different ramps. You can stop at any time by clicking the Stop button.
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•

Write down your Observation in the table below.
Task 4

Variant
1

2

3

4

Record
0
1
2
3
4
5
6
7
8
9
10
11

Accel./Decel.

Observation

2.8. Problems
Variant

1

2

3

4

Problems
3.1. Without current reduction, does the slide move easily or difficult?
3.2. What conclusion can you draw regarding the laboratory setup safety?
3.3. Is the SPC 200 always essential?
3.4. What must be done if slippage is suspected?
3.5. Calculate the drive resolution in the half-step mode
3.1. When is it required to apply the current reduction?
3.2. When a reference move is required?
3.3. What dictates the maximal speed of the step drive?
3.4. What should be done to decrease slippage?
3.5. Calculate the drive resolution in the full-step mode
3.1. How the current reduction is activated and deactivated?
3.2. How SPC 200 and SEC-ST are linked and what data do they exchange?
3.3. How can you change the speed of motion?
3.4. What factors define the resolution of the slide motion?
3.5. Calculate the drive resolution in the quarter-step mode
3.1. Explain a relation between the motor torque and current values.
3.2. Why do we need a pulse generator?
3.3. How accurate are the speeds that can be set for the stepper?
3.4. How the distance is defined the slide moves per the motor shaft revolution?
3.5. Calculate the drive resolution in the fifth-step mode

2.9. Report contents
•
•
•
•

functional diagram of the laboratory setup and the nominal data
texts of your programs
tables of observations for the tasks related to your variant
solutions of the problems related to your variant
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